Sum of Digits of a Five Digit Number in C - Hacker Rank Solution | Shaurya Coder

Sum of Digit of a Five Number 


 

Objective

The modulo operator, %, returns the remainder of a division. For example, 4 % 3 = 1 and 12 % 10 = 2. The ordinary division operator, /, returns a truncated integer value when performed on integers. For example, 5 / 3 = 1. To get the last digit of a number in base 10, use  as the modulo divisor.

Task

Given a five digit integer, print the sum of its digits.

Input Format

The input contains a single five digit number, .

Constraints

10000 <= n 99999

Output Format

Print the sum of the digits of the five digit number.

Sample Input 0

10564

Sample Output 0

16

Solution

#include<stdio.h>
int main()
{
    int n=0,sum=0;
    scanf("%d",&n);
   do{
        sum += n%10;
        n = n/10;
    }while(n>0);
    printf("%d",sum);
    return 0;
}

Post a Comment

Previous Post Next Post